Firefox 1.0.7? Tylko dla wybranych?

I znowu pojawiła się nowa wersja Firefoksa, z krytycznymi poprawkami
security. I znowu tylko w amerykańskiej wersji (chociaż podobno po
1.0.6 już więcej nie miało się tak zdarzać). Czyżby użytkownicy lokalizowanych
wersji nie byli zagrożeni? A może im się bezpieczeństwo nie należy? A może
wybór wersji innej niż American English to ma być świadomy kompromis lub
oznacza głupotę/naiwność użytkownika?

Wszystko wskazuje na to ostatnie. Niestety, nie łatwo tą błędną decyzję
poprawić. Już dwa razy próbowałem zmienić wersję językową i zawsze kończyło
się to niedziałającym profilem. Nie chcę tracić ustawień i zainstalowanych
rozszerzeń, więc pozostaje mi trzymanie się dziurawej wersji… A może jeszcze
raz zaryzykuję zmianę, tym razem robiąc backup profilu?

Na Operę się na razie nie przesiadam, bo co Open Source, to Open Source,
nawet w wydaniu Mozilli (zmieniaj co chcesz, ale nie będziemy ci tego
ułatwiać, a wydając nawet nie sugeruj, że to Firefox). Z drugiej strony…
i tak w tym Fx mam zamknięte pluginy i rozszerzenia… może więc jednak Opera?

Advertisements

7 uwag do wpisu “Firefox 1.0.7? Tylko dla wybranych?

  1. Po pierwsze, to że Marcoos tak twierdzi, to nic nie znaczy.
    Po drugie, wcale nie używam polskiej lokalizacji i moja wersja może być później.
    Po trzecie, skoro poprawione już jest, to czemu mam czekać do jutra? Wolę mieć dziury w tłumaczeniu niż w bezpieczeństwie. Ale Mozilla każe mi wybierać. Przy pierwszej instalacji — czy chcę wybraną wersję językową, czy szybkie uaktualnienia. Co gorsze, AFAIK nie informują o tym na czym polega ten wybór. Wersje lokalizowane przecież też są „oficjalne”.

    Lubię to

  2. Cóż, znowu Amerykanie zrobili nam ten sam stary numer – (którego więcej mieli nie robić) i wydali en-US bez paczek zlokalizowanych, do tego o drugiej w nocy CET, dzięki czemu zarwałem dzisiaj nockę na testowanie tego wszystkiego. 😉

    Z naszego punktu widzenia lokalizacja jest gotowa (tzn. jest identyczna jak w 1.0-1.0.6, bo wszystkie stringi są zamrożone), Mozilla.org ma po prostu głupie procedury/nawyki, które próbujemy zwalczać, ale nie zawsze się to udaje. 😦

    Procedura jest taka, że lokalizatorzy muszą przetestować wszystkie paczki dla swojego języka (Mac/ppc, Linux/i686, Win32) i powiadomić w odpowiednim bugu, że są one ok.

    Nawyk jednak jest taki, że ten bug pojawia się na b.m.o w chwili, kiedy en-US jest już wydane. Więc nie możemy certyfikować tych paczek wcześniej, bo nie jest pewne, że to są te właściwe.

    Jak do tej pory były dwie prawidłowo (symultanicznie) przeprowadzone lokalizacje (1.0 i 1.0.6), cztery poszły z obsuwem (1.0.1, 1.0.2, 1.0.3, 1.0.4). 1.0.5 pomińmy milczeniem.

    PS. To, co znajduje się pod adresem podanym przez Spidera, to są właściwe paczki, które będą (ale jeszcze nie są) oficjalnymi. W przypadku Linuksa istotne jest, żeby nie instalować paczek sprzed 21 wrz.

    Lubię to

Co o tym sądzisz?

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Log Out / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Log Out / Zmień )

Facebook photo

Komentujesz korzystając z konta Facebook. Log Out / Zmień )

Google+ photo

Komentujesz korzystając z konta Google+. Log Out / Zmień )

Connecting to %s