Jak naprawiłem sobie wczoraj laptopa

Wczoraj przed wyjściem na spacer zauważyłem, że laptop coś za bardzo szumi
wiatrakami, ale że wychodziłem, to to zignorowałem. Po powrocie próbowałem pracować,
ale strasznie się mulił, a wentylatory wyją. No to zabijam Firefoksa (nie raz
się tak zamulił, po odwiedzeniu jakiejś flashowej strony). Dalej muli. Na topie
na pierwszym miejscu xfce4-battery-plugin. Pewnie się zawiesił.
Restartuję panel – bez zmian. Wyłączam XFCE. Dalej wyje i muli… No to
wyłączam komputer i włączam ponownie.

Po uruchomieniu cisza i system szybko działa. No to super, problemu nie
ma. Pracuję dalej, ale po chwili, po uruchomieniu Xów i Firefoksa znów zawył
i zamulił. Wybijam co się da i load spada, ale sam top potrafi 15% CPU zużyć.
Najwyraźniej komp nie ma mocy. Sprawdzam temperaturę, tam gdzie mogę,
wiec tylko w /proc/acpi/thermal_zone/THM/temperature. 45
stopni, a więc praktycznie zimno. A wentylator wyje. Rozglądam się dalej po
ACPI i w /proc/acpi/processor/CPU0/throttling mam: T6:
75%
. No tak, działa na 25% mocy i to przy zegarze przestawionym z 1.8GHz
na 1.2GHz.

Wygląda na to, że włączyły się wszelkie zabezpieczenia przed przegrzaniem.
Ale dlaczego, skoro komputer zimny, z tyłu dmucha też zimnym powietrzem.
W sofcie nic ostatnio nie ruszałem, więc to raczej problem sprzętowy. Nie
spodobało mi się – nie najlepszy czas na umieranie laptopa, jeśli
dopiero co władowaliśmy w niego 300zł na nową matrycę.

Jedyne na co mogłem liczyć to to, że płyta główna i procesor, łącznie
z czujnikami temperatury, są sprawne, tylko gdzieś ciepło nie jest odpowiednio
odprowadzane. Zadzwoniłem do żonki z pytaniem, czy nie może przypadkiem skądś
sprężonego powietrza załatwić. Obiecała spróbować. I przywiozła puszkę.

Czas na chwilę prawdy… otworzyłem obudowę, przedmuchałem zawartość, ze
szczególnym uwzględnieniem żeberek radiatora przy wentylatorka. Skręciłem,
uruchomiłem i cisza. Piętnaście minut później dalej cisza i wszystko działa
sprawnie. Odpaliłem burnP6, wentylatory się uruchomiły,
/proc/acpi/thermal_zone/THM/temperature sięgnęło 79, ale komputer
dalej działał pełną mocą. Wyłączyłem cpuburna i wszystko wróciło do normy,
wentylatory ucichły. A więc usterka usunięta. Ufff… :-)

Advertisements

9 uwag do wpisu “Jak naprawiłem sobie wczoraj laptopa

  1. Arietta: Rurą od odkurzacza, szczególnie grubą i ssącą, efektywnie nie usuniesz kurzu spomiędzy żeberek radiatora w laptopie. Kurz zalegający w zakamarkach obudowy może wygląda brzydko, ale komputerowi najbardziej szkodzi to, co siedzi głęboko w radiatorach, wentylatorach i złączach.

    Lubię to

  2. @Arietta, tylko, że odkurzacze lubią wytwarzać ładunki elektrostatyczne, niech się taki spory przeniesie na radiatory i przy włączaniu mamy grzankę. Może i takie zdarzenia nie występują, nie znam się, ale kiedyś gdzieś mi się usłyszało. Poza tym, kiedyś czyściłem komputer odkurzaczem, miał za mały ciąg żeby wyssać kurz z zakamarków. Odkąd kupiłem sobie sprężarkę, to właśnie jej używam do czyszczenia wszelkich elektronicznych urządzeń.

    Lubię to

Co o tym sądzisz?

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Log Out / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Log Out / Zmień )

Facebook photo

Komentujesz korzystając z konta Facebook. Log Out / Zmień )

Google+ photo

Komentujesz korzystając z konta Google+. Log Out / Zmień )

Connecting to %s